uDriver board flashing issue

Ciao all,

currently we’re a bit understaffed because of the holiday period so I’m trying to flash the uDriver boards by myself. Note that I’m on a windows machine, not a Linux machine (possibly this is causing some issues as well)

So I managed to get through most of the steps in the explanation on Github, but I’m now stuck at the compiling part… I get a few errors and warnings that I believe should not be there. Hopefully someone can help me out with issue: @jviereck?

Hi Chundri,
we haven’t tried to compile the firmware on Windows lately. Is there a chance you can get hold of a Linux or Mac machine and try to compile there?

Otherwise, I noticed one of your folders contains a space in the name. This might screw things up. Can you try to move to a path without a space and see if the problem still persists?


Ciao Julian,

I later noticed that I completely skipped the first few steps of copying in the motorware from TI and patching this one file. Although the directory names in the explanation are a bit confusing (for the patching it talks about udriver_firmware, where in fact you need to be in the firmware directory inside of that directory)…

In the end I managed to flash all 6 uDriver boards which means the rest of the explanation is quite good as I don’t have any background in software. This also means that it is possible to compile the firmware on a Windows machine.

Next to this I would like to share with you all that you do not need the expensive Spectrum Digital JTAG emulator. I bought a very cheap XDS100 V2 emulator from ebay for 20 euro that worked fine as well for flashing. I also tried an Olimex XDS100 V2 emulator that costs about 60 euro and also this works well. I guess that would be good to share with other people since it is much cheaper (and maybe they already have one of these emulators at their university or research institute

Thanks for the help,



Hello, thanks for the alternative on programmer, we will add them to the documentation.


I am successfully flash using Ubuntu but now windows
Could you share how to flash using windows and with program you used?
I don’t know how to do patch in windows, I still have some error in Windows

I’m not on Windows, so can’t verify, but according to a post by a Windows user, the following command should work for patching on Windows:

patch {file} {patch} --verbose --binary

Apart from the patching, I think everything should work the same as on Linux.

1 Like

Thank you for the reply.
I have never apply file patch in Windows, so I will try to figure it out what to use,.
it’s usually easy using Linux via terminal.