Setting up for Solo12


I have two questions about the setup for Solo12.
We purchased Solo12 from PAL Robotics and are trying to set it up according to the wiki(solo12_hardware · machines-in-motion/ Wiki · GitHub).

The first question is about access rights to the repository.
I don’t have access to the repository(, so I can’t proceed with the setup.
How can I get access to it?

Second question is about the setup procedure.
I am using a ubuntu20.04 pc with preempt_rt patch and ROS2 galactic.
Can I run Solo12 with just the setup in the first link I showed?
Or do I need some other setup (like flashing the master board)?

Thank you.

1 Like

Hi Tjin,

at this point you don’t need the treep repo from tuebingen anymore. I’ve updated the wiki page. You might have to clone the repos using treep --clone-https, as you don’t have git-access to the repos. All repos you need should be public though, so cloning via https should work.

Note also that we assume the PC is installed using our official installation procedure and that packages from LAAS are available. You find the repo with scripts here: GitHub - machines-in-motion/ubuntu_installation_scripts: Scripts for installing dependencies useful for programming robots

About your second question, we have only tried the setup for solo with ubuntu18.04 and the corresponding dashing ros release. Not sure if they work with galactic or not.


Hi Julian,

Thank you for your helpful reply.
I’ll give that a try.